Trying to Disable PBA


We are having an issue with Voip phones going in and out of service. I believe this to be with PBA trying to apply a policy. There are countless entries in the log like the following:

133>Mar 1 08:25:24 ISS CFA: Port 11 (Gi0/11) Link Status [UP]
<133>Mar 1 08:26:35 ISS CFA: Port 22 (Gi0/22) Link Status [DOWN]
<133>Mar 1 08:26:35 ISS PBA: Cleared PBA policy #CambiumVoIP_If22 from interface 22 (application status change)
<133>Mar 1 08:26:38 ISS CFA: Port 22 (Gi0/22) Link Status [UP]
<133>Mar 1 08:26:40 ISS PBA: Applied PBA policy #CambiumVoIP_If22 to interface 22 (Auto-VoIP policy)
<133>Mar 1 08:26:40 ISS CFA: Port 22 (Gi0/22) Link Status [DOWN]
<133>Mar 1 08:26:41 ISS CFA: Port 22 (Gi0/22) Link Status [DOWN]
<133>Mar 1 08:26:44 ISS CFA: Port 22 (Gi0/22) Link Status [UP]
<133>Mar 1 08:27:56 ISS CFA: Port 22 (Gi0/22) Link Status [DOWN]
<133>Mar 1 08:27:56 ISS PBA: Cleared PBA policy #CambiumVoIP_If22 from interface 22 (application status change)

I would like to disable PBA entirely. I had first disabled it per interface and then globally, to no avail. I am still getting the log messages and believe it to still be trying to apply the PBA policy.

Here are the important parts of the config:

no pba
pba auto-vlan-status disable
interface gigabitethernet 0/22
no pba

Showing the PBA status even shows that it is disabled:

Device > show pba global
PBA Status: disabled
String Comparison: case-ignored
Update Port Description: pba-policy-name
Restricted MAC Match: enabled
Active Policy Reordering: enabled
MAC-based Policy Aging: disabled
Auto-VLAN Status: disabled
Auto-VLAN Server Trunk: disabled
Dynamic Uplink Support: enabled
Dynamic Policy Uplinks:
Device Localization:

What am I missing?


Hi @Brian_Jones
The commands you applied should stop processing all the PBA rules.
Do you see something like this below in your switch configuration?

I was able to get it to stop processing PBA rules only after I unmarked VLAN 2 as a voice-vlan (and the configurations commands as described above.)

Having PBA disabled with the ‘no pba’ and ‘pba auto-vlan-status disabled’ but still having a voice-vlan defined the switch still tries to configure the port and phone to use the voice-vlan. I guess this makes sense, but the log messages are a bit misleading as they make it seem that PBA is trying to make changes. (I guess that the underlying PBA programming is used to command the voice-vlan config?)

Regardless, in order to fully stop the PBA messages you need to have to disable PBA and not have a voice-vlan configured.

Disabling PBA is not enough. You need to disable voice-vlan setting on the vlan. You can disable voice vlan in the Switch Group on cnMaestro.
However, the root cause of your problem is the unstable link connection on port 22. You can run the command ‘show interface link’ to review the number of link flaps.

1 Like