Unable to complete PPPoE Discovery

Hi all, 

im using version 2.4.3 and SM logs says :

Jan  1 01:02:26 Cambium-Device pppd[741]: Interface ath0 has MTU of 1492.
Jan  1 01:02:41 Cambium-Device pppd[741]: Unable to complete PPPoE Discovery

 i tried using v 2.4.2 also, but problem continues, as PPPOE server im using a mikrotik, i disabled mschap 1 & 2. 

SM is in nat mode , mikrotik doesnt receive any request to connect but if i set the SM in bridge mode and the pppoe client in my laptop...WORKS...

im may doing a wrong thing....but dont know where...

any ideas???



We have a known issue with PPPoE in 2.4.3 firmware version. It should work on 2.4.2. Probably you downgraded only SM to 2.4.2, but left AP with 2.4.3. This is why it didn't work for you.

You can use 2.4.2 on both AP and SM or try 2.5-RC.



thanks Dmitry, you are rifht, just tried in SM only not in AP

will try later and feed back 

It would be interesting to also use the pppoe client MTU to 1500, this and 'possible with cambium?

PPPoE client in the ePMP SM can only support a maximum MTU of 1492 bytes.

there will be ' in the future the possibility ' of using pppoe to 1500 ? why not keep this into consideration , ? many manufacturers of other brands support 1500 pppoe

hi again, 

ive tried in workbench with to SM, both in  2.4.2  and also in 2.4.1 

doesnt work like in new version, were can i download th 2.5-rc ??


Hello Ginebra254,

Instead of trying different firmwares, maybe it would be more productive to try a wireshark capture of the PPPoE negotiation. For PPPoE to work,

- PPPoE server and client must be in the same broadcast domain

- Although optional, if configured in the PPPoE client, both Access Concentrator (AC) and Service Name must match between the PPPoE server and the client. Mikrotik uses the assigned router name as AC.

- Make sure user/password match in both client and server.

- If using a static IP address on the client side, the server must be configured to NOT assign an IP address to the client. If dynamic IP address is to be used on the client side, the server must be configured to assign an IP address to the client from a pre-configured pool of IP addresses.

- ePMP PPPoE client authentication ONLY supports PAP and CHAP.

You could also use the "tcpdump" functionality from the SM's CLI to do a capture.

Hope this helps.

hi luis, 

here you have screenshots of sm and mikrotik...

there is no pool as you can see, one ip per client, in this case its a new rb , so its empty . 


I see a mismatch of Service Name (service1 vs temp) and AC (MikroTik vs Cambium). Can you remove those two fields from the SM PPPoE configuration (leave them blank) or make them match the settings in the router?

IP configuration should be ok the way you have it for just one client.

hi, sorry if I insist , but I would understand if there is a possibility ’ of using pppoe with MTU 1500, or if you take into account the future implementation of the adsl 1500 MTU

Hello toto,

You can submit this idea for consideration here.



thanks luis, 

that missmatch was the issue, mow its connected to the RB without problems , many thanks to all who helped me!!!

ive been checking the log  and i saw this: 

Cambium-Device pppd[17725]: Interface ath0 has MTU of 1492 -- should be 1500.  You may have serious connection problems.

why it says that should be 1500?? 


Great! You can ignore that error. PPPoE currently only supports an MTU up to 1492 bytes. This error should have been removed from the software as it does not make sense. I will follow up on that.


Ok thanks

I have problem pppoe please help

se on video