Unable to SSH to ePMP from MikroTik Terminal with old algorithms disabled

Hi guys! how i can access by SSH from a Mikrotik Terminal to a ePMP in v4.7.x with old algorithms support disabled?
All settings i try say: “can’t agree on KEX algorithms”
I try enabling and disabling ‘/ip ssh strong-crypto’, test with 1024, 2048, etc etc… nothing work!

Thanks and regards!


Which software do u have on your mikrotik ?
There is ssh v1 on the old mikrotik firmware, which should not be used for security reasons.
Try updating to version 7.x.x on mikrotik

1 Like

Where is the ePMP device? Are you able to try with it being directly connected to the MikroTik to rule out any network issues? Also what RouterOS Version?

I have no issues from RouterOS 7.10 to ePMP


Hi, all my mikrotik network has last stable v7.x

Hi Daniel, the ePMP is directly connected and powered by the Mikrotik PowerBox.
I think i was clear in the post…
When the ePMP has the option “Deprecated SSH Algorithms” is “Enabled” or allowed, i can connect by SSH correctly…
The problem is when this option is not allowed “Disabled”

I like to add this security feature on my ePMP network, but i need to have SSH access from Mikrotik devices directly connected.
All the towers of my network is powered by Mikrotik PowerBox.

Just tried: mikrotik 7.9.2 → ePMP with “Deprecated SSH Algorithms” disabled and it works, successfully logged in.