upgrade_rule 4.3.4R8 to 4.4 not updating

I've dropped the new firmware files over place of my current firmware location and rebooted one of our R190V and 1 r201 routers... expecting it to update the firmware and it does not.  I've verfied the full URL of the firmware, including downloading it and pushing it to another router with success....

the URL is common to the model type through our config tree.  

http://firmware.mycompany.org/CNPilots/cnPilot-R190_current.bin   and like but changed for the 201

installing the firmware via this file name has worked for each step up in the past, but they are not taking it now.  

that said each router so far has updated to 4.3.4 from its out of the box config up to this point via that file name... will it not re-try and download the file if the file name is still the same?  if so... well thats a problem....  my hope was in the future to update all of the routers we have, is simply overwrite the corisponding firmware file and let them pull it on there 1 hour window thats defined by default. 

we use 3 steps to get to where we are with the config files... we use the generic file cnpilot-r.cfg file to get the model specific config, which interns supplies the proper upgrade URL and then changes the provision URL to (ma).cfg for the final configuration...


We tried similar 3 step process which you are doing in one of R201 and it worked fine.

Initially device was in 4.3.4-R8

1. Provision rule http://server/Cambium-cnPilot-R.cfg (this file has firmware upgrade rule with 4.4-R6 image and provision rule $(MA).cfg)

2. After downloading Cambium-cnPilot-R.cfg, device goes for firmware upgrade to 4.4-R6 from the upgrade rule

3. Then do final config download of $(MA).cfg

Please clarify below items,

1. In above steps, step1 you are doing via http or tftp?

2. Have you updated the Cambium-cnPilot-R.cfg file in the server with 4.4-R6 upgrade rule.

3. Please provide the steps you are following in detail, so that we can try the same to see if any issue is there.

before 4.4  this is our proccess  (which is still the same for 4.4) 

out of box factory router:

make a config file for the device, save in the correct location. 

boot the router at the end users home. the router boots and finds the Cambium-cnPilot-R.cfg file which only changes the provision file to (PN).cfg and setups our remote access and password

the PN file then defines the upgrade path for the correct partnumber router firmware.  then changes the provision to (MA).cfg

when it reboots again, it updates to the file  http://mycompany/firmware/cnpilot/modelspecificfirmwarefile

reboots and finally gets the final configuration file that gives all of the specifics, wifi name, key etc. 

this works fine with 4.4 with a NIB for the firmware upgrade.    

the problem is the routers that are already out there, don't check to see if the actual file has changed.  we use the filename cnpilot(modelnumber)currentverison.bin 

the filename cnpilot(modelnumber)currentverison.bin   used to be 4.3.4, I over wrote that specific file with 4.4 without changing the filename and the routers are not checking to see if its actually new firmware. My goal was to simply overwrite that file name and its done, all routers update. 

without bulk editing thousands of config files, is this possible to get these to mass pull and update or is this something that only happens once per upgrade rule update?  does it check again after a complete power loss?  

 EDIT - actually a bulk file update won't work either... 3 unique firmware files for the different routers. we have hundreads of each out there...  so i need them to be able to be able to check the firmware file and see a difference to know to download it.    if its not there, maybe a simple filesize check added to future releases?  

for the current update, is there a way to zip or chunk all 3 firmwares together and bulk edit the MA files to get them to pull the correct firmware?  If not, can i safely do this with all 3 verisons without the routers grabbing the wrong file and bricking themselves?



The device is not upgrading/ not initiating the new image update process as there is no difference in between running configuration and configuration of the (MAC).cfg file in HTTP directory.

  1. Please use the cnMaestro to upgrade image to the device.
  2. Append the same upgrade rule to the end of  (MAC).cfg file.
  3. Replace or update with the new rule in (MAC).cfg file.