Upgrading ePMP from version 2.0

We recently purchased a pile of ePMP devuces which are all on old firmware 2.0

I cannot seem to find an upgrade path that works. I have tried several versions from the most recent back down to 2.3 and they all fail with no real explaination as to why. 

Does anyone have a valid upgrade path from this very old version?

You will have to upgrade somewhat sequentially.  I don't remember the exact firmware versions required, but you will need to upgrade to 2.2.x first, 2.3.x next, etc.  If you read through the release notes there is guidance.  Also there are a few forum posts about it.

Regrettably, even trying 2.2 fails 

04/24/20 10:24:59 INFO Host: ;ESN: 000456C50100;Message: Current = 2.0, U-Boot 9350_PX 1.1.4.a (Oct 31 2013 - 19:28:30), 5 GHz Connectorized Radio with Sync (SITE= CambiumNetworks)
04/24/20 10:24:59 INFO Host:;ESN: 000456C50100;Message: Using Package C:\Users\bneyj\Downloads\ePMP-2.2.pkg3 (SITE= CambiumNetworks)
04/24/20 10:24:59 WARN Host: ;ESN: 000456C50100;Message: Sending Upgrade command with URL: (SITE= CambiumNetworks)
04/24/20 10:24:59 INFO Host: ;ESN: 000456C50100;Message: Upgrade command sent successfully. (SITE= CambiumNetworks)
04/24/20 10:24:59 INFO Host:ESN: 000456C50100;Message: Monitoring the device for Update. (SITE= CambiumNetworks)
04/24/20 10:24:59 INFO Host: ;ESN: 000456C50100;Message: Uploading image to device (SITE= CambiumNetworks)
04/24/20 10:25:05 INFO Host: ;ESN: 000456C50100;Message: ActiveVersion: 2.0 CurrentVersion: Version 2.0.0 (SITE= CambiumNetworks)
04/24/20 10:25:05 WARN Host:;ESN: 000456C50100;Message: Failed to upgrade device to 2.2 (SITE= CambiumNetworks)

Have you tried using the web ui on the radio?

The web interface worked with the tar files. 

I was easily able to bring it to current levels with one intermediate upgrade

1 Like

The first four threads I've found on this topic never lay out a specific upgrade path, it's always a broad generalization. It's helpful, but it's not the specific answer. Here is a specific answer.

Just did this successfully with a new in box ePMP 1000 2.4 GPS AP: 2.0 -> 2.4.3 -> 3.5 -> 4.5