Using snmp to change management IP Addresses

Having a really strange issue trying to use snmpset to change management IP Addresses on ePMP Bridged SM's

For e.g.

snmpset -v 2c -c public a

Gives the following error

Error in packet.
Reason: (badValue) The value given has the wrong type or length.

However, if I run the same command and change the IP to something else in the same subnet, it works fine:

snmpset -v 2c -c public a

iso. = IpAddress:

Why is this cambium?  I didn't use to have this issue with Canopy 100's!

Is there anyway around it besides rewriting everything to use SSH?

Not sure SSH is letting me change IP's either:

>config set networkBridgeIPAddr
Error: Parameter "" doesn't exist

Not sure what the issue is.  I've had success with this in the past (prior to 3.5.1)

I figured out that I was getting the SSH error only when logged into an SM via mac-telnet.  I was trying to rescue an SM that my script only made it half way through before choking on an error

Once I connected via SSH the config set command worked.

But now that I think about it, it is kind of worrying that you can’t set IP addresses through mac-telnet.  You would think it’s the same exact shell with the same commands available