VLAN issues cnmatrix

I am struggling to get simple vlans to work on the TX2020R-P. Coming from the netonix world, if I wanted to have a simple untagged vlan coming in, I just untag vlan 1311 and boom, i’m good.

When I go to the static VLAN page of the matrix and untag 1311 to the ports it does not work, I just lose access to everything. If I plug a netonix into the same uplink with 1311 untagged I get online instantly. I just tried going to the port tab as well and made my uplink port an access port of 1311 and still nothing.

Coming from Netonix the UI of these is pretty frustrating to work with. Any ideas on what i’m doing wrong? The documentation I found did not help me much.

The cnMatrix does require a little bit more configuration than a Netonix switch when setting up vlans. Can you post your current vlan configuration? I am going to guess either the configuration is corrupt and requires a reset or the PVID for the ports is not changing when you untag vlan 1311.


Hello, untagged VLAN applies to the egress direction. To process untagged frames arriving at the port, you need to configure the port’s PVID. You can do the configuration via the Web GUI and CLI.

1 Like

Unfortunately, this is how it ends when you switch from equipment whose manufacturer did everything in his own way to make it easier for users :frowning:

In Cambium, everything looks almost identical to Cisco, Netgear, Fortinet and many other mature manufacturers

this is example where port 0/1 is access port in vlan 22 and extreme-ethernet 0/4 is tagging that vlan (in my case that is uplink port), but you can export your config (put description or define to us which port is uplink uplink port (if there is a need to carry that vlan to some other device)

vlan 22
ports gigabitethernet 0/1 extreme-ethernet 0/4 untagged gigabitethernet 0/1
name VLAN22
interface gigabitethernet 0/1
switchport pvid 22
switchport acceptable-frame-type untaggedAndPriorityTagged
switchport mode access

1 Like

When I set the PVID I get a generic error. What am I doing wrong here? Is there any documentation for doing VLAN through the GUI on these switches somewhere?

Please make sure the port is a member of the VLAN before setting the port’s PVID. Note that pvid and untagged port settings are different as pvid is for incoming untagged frames, and untagged port is for transmitting untag frame. To add a port into a VLAN:

I have VLAN 4003 untagged coming to port 8 of the switch with these settings and it is not working. Are there any other configurations I need to make?

To vlan config add taged port - “8-9”
Change hybrid to access
Save test again

Thank you for the assistance. This configuration change did not work and resulted in an error.

Have a great call with @TamN and he straightened me out. The quick version is: Use Cnmaestro for configuration! It simplifies so many things. Once he showed me where to configure everything in Cnmaestro everything worked perfectly.

Wonderful support from Cambium though, absolutely thrilled to have a manufacturer that actually supports us.


But still issue with GUI remain right?

The GUI certainly is not good, it has a lot of limitations and requires sooo many clicks to accomplish anything. Cnmaestro is the way to go. I still have to click a ton through many screens to accomplish my tasks but it works. Hopefully their UI continues to improve in a more cohesive manner.

At the end of the day I can accomplish all of my needs through Cnmaestro so I am relatively happy.

cnMaestro acts as a point of truth and if you’re editing in the GUI or CLI, cnMaestro will override it.