VOIP QOS settings


We are trying to deploy VOIP over our Canopy network and are having trouble getting it to work reliably. We are experiencing extreme choppines with the upstream voice traffic. After dealing with Canopy support and reading the related posts here, I have enabled QOS on the SM, AP, and BH’s on our test bed, but see no change in call quality.

We are running 5.7 GHz SM/AP’s and 5.2 GHz BH’s all with software scheduling and 7.2.9 firmware. We are using Linksys PAP2 VOIP adapters and Linksys WRT54GL routers.

The QOS settings I have tried are as follows:

Linksys PAP2:
SIP TOS/DiffServ Value: 0x68 (default)
RTP TOS/DiffServ Value: 0xb8 (default)

DSCP 46 priority 7
DSCP 52 priority 7

DSCP 46 priority 7
DSCP 52 priority 7

Downlink Data 75%
High Priority Uplink Percentage 25%
Total NumUAckSlots 6 (Range: 1–7)
UAcks Reserved High 3
NumDAckSlots 6 (Range: 1–7)
DAcks Reserved High 3
NumCtlSlots 6 (Range: 1–16)
NumCtlSlots Reserved High 3

DSCP 46 priority 7
DSCP 52 priority 7

High Priority Data Queue enabled

Has anyone got VOIP to work reliably with a similar setup? If so, what QOS settings are you using? I have seen other TOS/DiffServ values suggested but have not seen a good explanation for these values. Any help would be much appreciated.


Install software 7.3.6.

Also try changing the downlink % to 50 instead of 75.

Are you saying that QOS does not work with 7.2.9 firmware? Should we upgrade all of our equipment (SM, AP, BH) to 7.3.6? I remember reading a post that stated not to run anything above 7.1 on BH’s- can anyone tell me the reason for this? Can anyone using the Linksys VOIP adapters tell me what the TOS/DiffServ values should be? I am currently using the default values.

Read the release notes on the 7.3.6 firmware. I remember seeing something about how 7.3 will help with the priority setting in the SMs/AP’s.

I upgraded the SM and AP to 7.3.6 but see no change in the quality of the upstream voice traffic. What am I missing???

Have you ran a link test on the sm unit?

Do you have “high priority” ENABLED? Just checking. :slight_smile:

Yes, high priority is enabled all the way through. You can see my entire config in my 1st post. Here is the result of the link test from the SM:

Stats for LUID: 10 Test Duration: 6 Pkt Length: 1522
Downlink RATE: 2590720 bps
Uplink RATE: 1284437 bps
Downlink Efficiency: 99 Percent
Max Downlink Index: 98
Actual Downlink Index: 97
Expected Frag Count: 30360
Actual Frag Count: 31044
Uplink Efficiency: 100 Percent
Max Uplink Index: 100
Actual Uplink Index: 100
Expected Frag Count: 15052
Actual Frag Count: 15052

I am very suprised with your downlink and uplink rate if you are running advantage? I’m running a cyclone and the p-8 sm units. We don’t push the voip phone’s but have several customers with them. I haven’t heard one complaint.

I’m also at 75% on my ap

Stats for LUID: 25 Test Duration: 2 Pkt Length: 1522
Downlink RATE: 3545088 bps
Uplink RATE: 900352 bps
Downlink Efficiency: 100 Percent
Max Downlink Index: 91
Actual Downlink Index: 91
Expected Frag Count: 13848
Actual Frag Count: 15086
Uplink Efficiency: 100 Percent
Max Uplink Index: 97
Actual Uplink Index: 97
Expected Frag Count: 3517
Actual Frag Count: 3517

You are fine by running the default settings in the ATA just as long as all the equipment matches. The main reason for not running 7.2.9 or higher on the BH’s is if they are colocated and in the same band one link will drop out. The only reason to run 7.2.9 or newer in the BH’s as far as i can see is for the Diffserv feature. 7.2.9 had a bug with VOIP that 7.3.6 fixed although I never experienced it with our VOIP. As far as your problem the best i can tell is your settings are ok but you must remember in order for QOS to work it is a ALL OR NONE feature. Everything from the ATA to the VOIP gateway must have QOS. If and I am just guessing you are putting the ATA behing the WRT54GL on one of the switched ports. If so the WRT54GL i dont believe has QOS so you are just wasting your time. For a simple test try using the ATA without the router in front of it and see if it improves. If you provide the VOIP gateway QOS is easier to manage but if you dont the best you can do is make sure all your equipment all the way to your ISP is running QOS. Choppy voice can also be attributed to lost packets, for instance if the buffers are set wrong on the core router at your isp it can dump the packets. In this case it wont matter what settings you have. Hope this helps. Dont give up good quality VOIP can be run on Canopy I did it without help from the black bat.

I’ve upgraded all SM’s, AP’s, and BH’s on my testbed to 7.3.6 and still see no change in VOIP quality.

We hooked up a Packet 8 voip adapter to a Canopy SM and it worked very well. The only apparent difference in the Packet 8 adapter’s config compared to the Linksys PAP2 is that it uses the g729 codec. Right now we are limited to using the g711 codec which uses much a much bigger packet size of 64k compared to 8k for g729.

Can anyone who has gotten voip to work over canopy tell me what codec you are using?

We are using both g29 and g711, take a look at your packet size on g29, if you go into a sm and to a link test with that sm and enter in the packet size that you are using you will notice a problem there with the link test. If the packet size is not optimal for canopy the link will degrade.

We havent seen this until now so we are still playing with our settings.

Using a Sipuara ata our packet size is 78bytes. Canopy recomends 1500 bytes for optimal.