XE3-4 wwan 4g dongle not working

Hello everyone,
I’m experiencing an issue with XE3-4 access point (fw version 6.6-r8) and Huawei E3372 usb 4g dongle. Tried with different sim cards but still no internet connectivity to the AP. The usb dongle works fine when connected to a computer. I tried powering the AP using both poe injector and cnmatrix poe switch. Tried setting wwan via cli (the GUI is buggy, since the settings in the wwan section disappear after being saved). Nothing helped.
Any advice is appreciated


USB enabled in the AP Group ?

Actually, I was testing it accessing the AP locally, without having it onboarded on Maestro…

Please try will be faster

I did try but nothing changes. After setting wwan up via cnMaestro I also checked the AP config via cli (show config command) and wwan is indeed active but still…no internet connectivity.

I understand that you are testing this when you do not have Ethernet connected to the Internet?
I use this same model in the xv2-2 device. It works without any problems.

Did you use any specific setting to make it work? It is my understanding that once wwan is enabled I should get internet as soon as I plug the 4g dongle in. Is that right?

Does the dongle require configuration or “dialer” software?

Hi @MauroV ,

I have tested the same scenario with a XE3-4 access point loaded with 6.6-r8 build and with HUAWEI-E3372 USB dongle. It is working perfectly fine in my testbed. My wired client connected to Eth-2 port of the AP and a wireless client connected to the same AP are able to access internet without any problems.

The Sim network i have is AIRTEL.

So the conditions to be satisfied while using a cambium access point will be giving the proper APN name. For my AIRTEL network the APN is “airtelgprs.com”. The APN name “internet” is common for all other networks we use and different APN names for few other networks. please check if the APN name is configured correctly.

Optional configuration but recommended is giving the monitor host. please configure the monitor host as “” or “www.google.com” or any other common website in the internet.

After configuring the above conditions please check your setup if you are able to access the Internet or not.


There is no need for “dialer” software as users need to configure the APN details in AP.

As you suggested, I set the APN and monitor host address. The 4g dongle’s led shows that the lte connection is established but the AP won’t reach the internet.

Please create a support ticket on this and send the ticket ID or send the email to me (niraj.mahapatra@cambiumnetworks.com)with tAP ech-support, LTE ISP, and APN details.