XV2-T0/T1/-21 WiFi instability

I am having WiFi stability issues with the XV2-T0/T1 and 21. When I broadcast a SSID with both 2.4 and 5ghz selected, my android and windows devices will connect but bounce between each channel every second, back and forth. sometimes it stops, sometimes only one devices does it, sometimes no devices does this. If i seperate the frequency to their own SSID (_2G/_5G) the devices will connect, authenticate, get an IP and then immediately disconnect and repeat over and over. I have disabled all the extra settings, like Proxy ARP, Bock broadcast, bandsteering, and even the Security functionalities. I have lowered the power levels to put a huge separation between the frequencies. Nothing has fix this issue, except to reboot the AP’s will help but only for the issue to return. Firmware, but have tried the 6.5.1r11 firmware too with no change. Anyone experienced this Issue as well?

1 Like

@Thomas_Schmidt , the firmware versions do not match the product. The XV2-2T0/2T1/21X should be on the 6.x release train. The latest is 6.5.1-r11. Could you please recheck and confirm?

yes I miss typed Im currently running 6.5.1r11, and on others. all AP’s have the same issue

@Thomas_Schmidt Can you please share the techsupport file to vtr100@cambiumnetworks.com? “AP UI Login → Operations → Download Tech Support”
Note : It would be helpful if you can collect the techsupport file while the issue is seen.

Also need following information to have better clarity on the issue.

  1. How many AP’s are there in the location? If there are multiple, the floor plan would help to understand the network.

  2. Is there any particular model of client device facing issue or all the devices? If any particular device, then can you please send the device model details.

  3. Did you try connecting the client having it closer to the AP just to rule out the RSSI related issues?

This issue is not RSSI related, as no matter how far or close you are to the AP’s, the problem still exists. The layout is a mix of indoor and outdoor but is not important, as I set up a single XV2-2Ti in my LAB to test, and while working at another cambium tech via email, the problem still exists with the lowering of the TX power, and changing various settings. I was just at the Clients location this weekend, and I got his phone connected on the AP, but only a few hours later did they drop off and went into the continuous connect/authenticate/IP/Discconnect state over and over and over. It is like the AP’s are kicking the devices off, they had to plug in their old router again. This is happening on Android, Windows PC and Linux/Ubuntu PC’s. This weekend, My phone which is android worked pretty good, but yesterday it refused to connect, and my son’s VR Quest2 would not stay connected so I had to revert back to my Mikrotik AP. attached is a Tech file, it will show roaming of the devices, but there is no roaming as the this is from the single Cambum XV2-2T1 I have setup in my LAB.

@Thomas_Schmidt Thank you for sending the techsupport file.

We understand from the config that VLAN1 interface is been deleted. This issue will be resolved if you add VLAN1 L3 interface . Our Roaming XRP protocol is dependent on the same so the client is continuously kicked out and anonymous roamed event appears .

To add VLAN1 L3 interface "AP UI Login → Network → Under VLAN “Add New L3 interface” → VLAN ID “1” → Save

Kindly config as mentioned above and let us know if you still observe the issue.

1 Like

Hi @Viky_Cam

just to understand:
we need, in our networks, a vlan1?

It’s common, for me, to NOT have any default/unused vlan across my networks.

Thank you

1 Like

Just for reference…
Mikrotik client serving wifi, is some of the worst I have ever seen.

A driver that is stuck in 2014. Radios that stop handling traffic if there are nearby radios. No MU-MIMO. Garbage throughput. etc etc etc.

Caps-man would be the greatest management thing ever, if it talked to good radios… But it talks to Mikrotik radios.

I agree. I strip all network equipment of defaults and program with my selected VLANs only. but so far adding VLAN 1 back onto my LAB AP has remained stable.

1 Like

You, like many others, have your rightful gripes with Mikrotik, but I love Mikrotik because it just works. No they are not perfect, but I can set up an AP is minutes and all devices connect and pass traffic perfectly. Im new to Cambium and was really looking forward to the great possibilities that Cambium has over Mikrotik. But it’s sad that I still have to rely on my Mikrotik AP to remain connected to the Internet to find a fix for this Cambium disaster.

I have made the change, so far things look stable, but I will keep this post updated as the day goes on.


Is the same for cnPilot 4xx/5xx?

No, It is not the same for cnPilot E500 and E400. These are old APs and running with 4. X images.


I get the point that default configuration such as VLAN 1 is not used in deployment and is considered as basic security.

In this case, VLAN 1 is allowed in ethernet configuration in-spite of other VLAN ID being management interface, which was causing trouble.

If VLAN 1 is neither configured nor allowed either in ethernet or in interface, it will work as expected.

Thank you.


Thank You Cambium Support, I have modified the Native VLAN to 5(my MGMNT VLAN) and Tagged it, as well as reinstated VLAN1 on the Ethernet. The Roaming issue has seemed to be resolved and the AP’s are working properly. My OCD really wants to delete the VLAN1, but until this bug is fixed in firmware, I’ll just wait.

Sorry, I don’t understand, to me these are conflicting.
Can you elaborate?

Thank you