cnMaestro taking forever to load groups or networks

Is anyone else having this problem? It takes Forever for my cnMaestro to load up a network or group. Once it's loaded it runs like a champ but to get it to that point just takes a good 15-30 seconds per group to load. 

Maybe i'm impatient but this is a recent change as it use to never be this slow. I'm on a 1 Gbps dedicated fiber with an office building of 8 people so I'm confident that I don't have a bandwidth problem. I'm curious if anyone else is having this issue. 

1 Like

Are you using the cloud version or onpremise? We have over 1000 devices onboarded into the cloud version and everything seems fine and loads quickly.

Have you tried clearing your cache or trying to use it on a different computer/browser?

1 Like

Hi Thomas,

Can you please let us know how many devices (approx) are organized under each AP Group or how many nodes (devices, towers, sites) are there under the individual networks are there? Also the cnMaestro release version and the deployment type (cloud/on-premises) will help us try and simulate the problem. 


1 Like

We have on-prem 2.2.0. 

We just imported a large chunk of SMs (over 1000), and the system is barely usable now. I think it is the topology tree that is bogging down the web browser.

I believe the mistake we made was not importing the APs first, so that possibly the SMs would "nest" under the APs, and therefore not show so many entries in the topology tree. Hopefully once we get the APs onboarded, the problem will correct itself.

The developers might consider paging the results, so that only a subset of the devices in the tree load, unless you scroll down, which would trigger loading another subset.

1 Like

After adding the APs, the system is still not usable. I can't tell, is it doing something in the background, trying to assign SMs to the APs? Here's some of the console messages that repeat over and over again.

13:0:42:854 - cns.common.component.tree.service.hierarchicalService : Count of nodes under network default is


vendors~cnmaestro-client-2.2.0~cf067c.min.js:310 13:0:42:856 - : Trace>> cns-ws.actions.hrchy.refresh {stream: "start", tree: "nw", mcid: "", nid: "default"}

vendors~cnmaestro-client-2.2.0~cf067c.min.js:310 13:0:48:925 - cns.common.component.tree.service.dataService.CNSTreeDataService : AssignChildren ==> executed for default in 5.443 seconds

1 Like

Issue was due to a bug in the newer ePMP radios with newer mac addresses (58:C1:7A) need to have 3.5.6 firmware installed. The older firmware detects the MAC address as containing FF:FF:FF as the last 3 octets. When Maestro sees one and then more than one device trying to connect, it gets confused and goes into a constantly refreshing mode.

Here's another thread with more detail:

Maybe Cambium can write into Maestro to also look at the serial number to distinguish these devices, otherwise you'll want to make sure you're using 3.5.6 on all SMs in the field, before they connect to Maestro.

Sorry for such a massive delay on this.

We have approximentally 3,500 units on cnMaestro and this is happening on phones, and different work stations. On both 1gig connections and 10 meg connections. 

It takes so long to load but once it's loaded it's pretty quick until we get to a new menu.