cnut 4.8.1 ubuntu

The new CNUT release is not installable on ubuntu anymore. there seems to be a depedency to dos2unix package, but although it's installed, the installer stops.

Officially, CNUT is only supported on Redhat distributions and derivatives. Fedora, RHEL, CentOS, etc.

1 Like

I was able to install version 4.8.1 under Gentoo with a little hack. 

The setup tries to 'find' dos2unix using this command line:

rpm -qa --qf="%{n}.%{arch}\n" | grep -i dos2unix | wc -l

I just created a file name /usr/local/rpm with this content:

echo dos2unix

The command line then returns a '1' instead' of a '0' and the install process continues.

The check in the installer should be something like:

which dos2unix

Just my 2 cents!


Great script!! Thanks Ju!

I was able to install CNUT on Mint (which uses apt-get for packages)

But I suggest to exec the following instructions to create the script in the right path, /usr/local/bin:

echo -e "#!/bin/sh\necho dos2unix" >/usr/local/bin/rpm"

chmod +x /usr/local/bin/rpm

1 Like

I have tried placing a dos2unix file in both the above mentioned places and i cant get the rpm command to produce a 1. can anybody help me out? Ubuntu distro.

I just installed on ubuntu...

you have to place that rpm file in /usr/local/bin/

it will work like a charm

anyone still having this issue with 4.10.5 cnut?

I have tried the steps above and nothing happens.

was able to get 4.8 CNUT to isntall in ubuntu but not 4.10.

Any plans on ubuntu support for new verision of CNUT?

Kindly provide more details, like how the installer stops. Screenshot would be a help.

I just installed 4.10.5 on my Ubuntu workstation, overwriting 4.9.18, with no trouble.

In /usr/local/bin I have the executable script "rpm" containing:

echo dos2unix

While dos2unix itself is installed and lives at /usr/bin/dos2unix.

If you're still having trouble with this we can help.  As Piyush commented, more details on the actual error would help, as would the contents of /tmp/bitrock_installer_****.log (the **** is a 4-digit number, there will be one file for each attempt to install since last reboot)


Based on all the respones on this thread (I had the same issue as OP trying to install in on ubuntu 16):
apt-get install dos2unix
nano /usr/local/bin/rpm
    echo dos2unix
chmod +x /usr/local/bin/rpm
chmod 775

It no longer gave the "dos2unix not installed" popup box error, but the window disappeared and it didn't seem to be doing anything. I tried it a couple of times and then just let it run for a few minutes and got a message box that looked similar but had the following text:

There has been an error
Error running find / -type d -name uninstall_CNUT:
find: "/run/user/1001/gvfs": Permission denied.

I get the same Error Anyone fix this

To bypass "Error running find / -type d -name uninstall_CNUT:
find: "/run/user/1001/gvfs": Permission denied.", you need to temporarily unmount gvfs before running the CNUT installer:

umount /run/user/1001/gvfs

1 Like

Me podrian pasar el instructivos para instalar CNUT4.8.1 en Linux Mint.