Hi All,

I’m having some troubles with some dot1x/radius issues (I’m not sure which) which was solved by upgrading the OS, but I realised that my debugging skills were lacking and I was just taking a shot in the dark with an upgrade. I’d like to be able to find and fix things myself.

I don’t have console access to the switch, so it has to be visible in an ssh terminal.
On cisco I’d turn on terminal monitor and enable debugged for whatever I want but I cant see the option for that on cnMatrix

Current settings i’m using:

logging on
logging facility local0
logging buffered 300
logging severity debugging

debug dot1x all
debug radius all

Thanks all,


I can confirm that radius stuff are not fixed, I reported that 6 months ago, and they told me that my bug reports are fixed (fw 4.2 in august releaae notes).

Regarding debug commands, also i got nothing on ssh.
I also asked is there any command needed to enable debug message preview in ssh connection… no answer.

My biggest issue was that radius auth is not working if you put domain name for radius host.
They release new firmware wich says it is fixes but still working only if you out IP address for radius host.

They “fixed” bugs and put a new firmware out without any checking… shame

Sorry to hear you are having problem with the radius domain name. Our record indicated the DNS name for radius server was supported in release 4.1.1. The 4.2 release is not available. Please download 4.1.2 (released in Oct) on Cambium Support site. Please also share your ‘show running-config’ for our investigation.

Debug message is currently printed on console and telnet session.
Please follow the steps below to enable debug session.
Enable telnet connection: config terminal;telnet enable
Connect to telnet session, and enable debug message on telnet: config terminal;debug-logging session

1 Like

Thanks Tam,

It wasn’t a DNS issue, the radius server was set to an IP. The latest version fixed it anyway so we are happy to use that.

Debugging only over console or telnet is useful info though. I’ll record it in my documentation.



2 posts were split to a new topic: Using DNS name for Radius server