Device Approval Pending - already been approved


I am trying to onboard some R190V routers

In the cloud it says waiting for device, and I have already approved it. 

In the router on the cnmaestro config tab it says device approval pending. 

I have tried firmware updates, deleteing the router out of the onboarding queue and re-claiming it but it still wont update the router. The router just says waiting approval and the cloud onboarding queue says waiting for device. 

Any idea what could be happening?

1 Like

It shows the CambiumId too on the device where its on boarded right? Do you see where it was claimed and you are looking at onboarding queue on the same account?

Kindly send me the serial no of the device via private message and I can check from the logs where this device is connected.



I have sent through the email now with screenshots. 

1 Like

This is fixed now, please check.

All working now - was an issue with the cambium cloud server 

1 Like

I have the same issue in our account with an entry in the Onboarding screen that cannot be approved/unaproved or Deleted as it comes up with a message that the device does not exist. How can we get rid of this entry in the onboarding screen which we do not need? We have all our other units onbaorded and working correctly.

1 Like

Hi Sebastian,

Can you please send me the screenshot via private message.



1 Like

I have fixed in your account by removing this device.


I have the same issue in our account with an entry in the Onboarding screen that cannot be approval pending Pls help us

1 Like

I have the same problem today on 2 out of 4 E410.

Connecting directly to device, appears as:

cnMaestro Connection Status: Device Approval Pending
Connecting to cnMaestro the device appears as offline
Pinging the cnMaestro URL from the device, there is connection and its working fine.
One of the E410 i tried to factory reset, delete from cnmaestro and add again. It did not work.
1 Like

Is this cloud account or On-Premises?

If on-premises what is the version?


same issue with a r190w. still waiting on device acceped it two days ago

Can you send me direct message with cambiumId and your device MAC address.

1 Like

Hi  gpieric


I saw your account and it has only 1 device, it seems your device is still not connected with maestro.

When you click approve unless the device is connected with maestro it wont be onboarded.

Please check device logs and see if its able to reach cloud.

i did a factory reset and will start over, im trying to decide if i like this product and way of managment to see if I want to switch for all my routers.

i still cant get the device to onboard says waiting on device

Can you please login to your cnPilot R device GUI and enable DEBUG level for syslog
Under Administrator->Management

After this reboot your device and let it re-connect again with cloud.

Then just go under Status->Syslog page and see the logs what it says when it tries to connect with


i walked away from it over nigh and it finally went

You mean it shows connected now?