Issues elevating Ubiquiti devices with firmware higher than 5.6.15

Hi Everyone,

We are trying to elevate some devices here in the office before we test them in the field. 

We could easily elevate Nanostations 2.4, but we are having issues with the PowerBeams. 

I made sure we were using the XW firmware, I did read a bunch of forum discussions about it. I also tried to use the elevator tool available at this link: 

Tried with different Elevate firmwares: 

From XW 3.5 to XW 3.2

Unfortunately the Ubiquiti interface says: 

This firmware is not trusted by airOS. To maintain security, it will not be loaded. Please load trusted firmware.

I tried to upgrade the Powerbeam to 6.1.0 and downgrade it to 5.6.15 (the lowest firmware Ubiquiti would allow you to use) to no success.

Any suggestion? Thank you.


Please check this thread to see if it helps your situation.



I found the solution myself. I hope this will help others in my same situation.

The bottom line here is that AS OF NOW (please check the date of this post) you CANNOT downgrade a ubiquiti device to a firmware lower than 5.6.15. 

In order to elevate a Ubiquiti device you need to have it (ideally) on 5.6.6

Some guy from Nepal shared some BETA firmware that allowes you to downgrade any device to 5.6.6

I put the file on this link

Procedure: (works on both XM and XW)

1) Downgrade device to 6.0.6 beta

2) Downgrade to 6.0.4 (beta)

3) Downgrade to regular 5.6.6

4) Install elevate firmware (3.5 it's the most updated as of now)

Works like charm

You will be able to elevate any Nanostation or PowerBeam by following this procedure.


hello you can upload it again 5.6.6 file because the link does not work

Please share us again the link for download it May you share us also a link for LiteBeam M5 ?