Link Planner google maps crash, resolution?

I’m routinely having the issue where I can’t use google maps. I have to disable that else I get non-stop crashes.

Is there a fix on the horizon for this? It’s very irritating and makes it really difficult to do any planning because it’s a bunch of copy/paste GPS from google maps.

This has been a re-occurring issue and is still a thing in 5.6.1


Unfortunately we have been unable to reproduce the problem so we don’t know what is causing it. A clean Windows 10 or Windows 11 build works without any errors when we try it.

The online map view is using the MSHTML ActiveX control. This is old technology now and it’s possible that you have configured your machine settings to disable ActiveX or prevent scripts from running in this environment. We’ve tried to recreate this in-house, but we have been unable to trigger the crash. To make things worse, the embedded online map has to run in IE10 compatibility mode. Without this, the communication between LINKPlanner and the embedded map is not possible.

In time, we will be moving to an online version of LINKPlanner so everyone, including Mac users, will have access to the map. If we get a fix or workaround for the crashing issue in the short-term then we will let you know.

Sorry that this isn’t really the solution that you were looking for, but we don’t have a fix at the moment.



Ok, well that’s good info and I think I’ve found the cause. There is a remote code execution vulnerability in Windows that is unpatched and my AV/AM software is blocking execution.

1 Like

confirmed. Windows defender and bitdefender both block MSHTML activex execution. I would imagine this is a common block. Excluding just Linkplanner.exe doesn’t do it, have to exclude the entire linkplanner folder and then it loads.

also note for anyone that finds this thread, you have to ‘undo’ these settings by pasting this into an admin command prompt to bring maps back


Excellent - thanks for your help resolving this.

If you are having problems with the online map in the desktop version of LINKPlanner, you may want to try our new online version, see LINKPlanner V6.0.0 now available in your browser for more details

I got this error on WIN11

PS C:\Program Files\Cambium Networks\LINKPlanner> setx LINK_PLANNER_HIDE_GMAP “”
ERROR: Invalid syntax.
Type "SETX /?" for usage.

The syntax appears to be correct. Check that your quotes aren’t “smart quotes” - you just want the standard double quotes and not the ones that Office insist on inserting into documents.

If that doesn’t work, search for “Windows 11 remove environment variable” and follow the instructions from there.



the culprit is Bitdefender.
After I reset Protection/Antivirus setting, setx run correctly