LINKPlanner 5.0.0 fails to start

LINKPlanner 5.0.0 fails to start and the error message says see LinkPlanner.exe.log for details.

LinkPlanner.exe.log contains the following:

Traceback (most recent call last):
File "link_planner\wxapp\application_base.pyc", line 64, in OnInit
File "link_planner\wxapp\application_win32.pyc", line 77, in create_main_frame
File "link_planner\wxapp\main_frame.pyc", line 42, in <module>
File "link_planner\wxapp\statusbar.pyc", line 8, in <module>
Status bar for the MainFrame class.
File "link_planner\wxapp\wx_pubsub.pyc", line 4, in <module>
File "link_planner\wxapp\pubsub.pyc", line 5, in <module>
ImportError: No module named pubsub
OnInit returned false, exiting...

Hi Patrick,

It looks like you have installed LINKPlanner on top of your old version. Can you uninstall the old version first since that file is being loaded by the new version by mistake. The alternative is to install into a new location.

Since this is a 64-bit version it should really go in "c:\program files" instead of "c:\program files (x86)", but the installer remembers your choice from earlier installs unfortunately.

Let me know if you still have problems.



1 Like

This appears to have been resolved by installing LINKPlanner 5.0.0 into a new directory, i.e. not over the existing LINKPlanner 4.9.1.

1 Like

I've added a note to the download page to warn other users.

1 Like

Thank you!


I am still having trouble with this. I did not previously have LinkPlanner 4 so it was a fresh install.

I first installed it to Program Files (x86), then uninstalled and installed to Program Files and it still did not work. I went further to install it to my D Drive partition and it is still not working.

Can you please assist me on this?

The errors are as follows;

1. See the logfile 'D:\Software\Cambium Networks\LINKPlanner\LINKPlanner.exe.log' for details.

2. The log file states: OnInit returned false, exiting...

3. And the unexpected errors shows:

Traceback (most recent call last):
File "link_planner\wxapp\application_base.pyc", line 64, in OnInit
File "link_planner\wxapp\application_win32.pyc", line 93, in create_main_frame
File "link_planner\wxapp\application_win32.pyc", line 84, in __init__
File "link_planner\wxapp\main_frame.pyc", line 574, in __init__
File "link_planner\model\preferences.pyc", line 720, in duplicate_config
wxAssertionError: C++ assertion "!IsNumericValue(szValue)" failed at ..\..\src\msw\registry.cpp(1041) in wxRegKey::QueryValue(): Type mismatch in wxRegKey::QueryValue().


This is one that I haven't seen before. It looks like it could be an issue with your system registry - possibly lack of permissions.

- Click Start -> Run (or Windows Key+R)

- Type "regedit" into the textbox and click OK

- Navigate to HKEY_CURRENT_USER\Software\CambiumNetworks\LinkPlanner

- Rename the "LinkPlanner" folder, (e.g. change to "LinkPlannerBroken")

- Start LINKPlanner

If you have previously used a very old version of LINKPlanner (v1.x or v2.x), then you may have a HKEY_CURRENT_USER\Software\MotorolaPTP\LinkPlanner directory. If this is the case, you should remove it. LINKPlanner tries to copy the settings from the older version, but since that hasn't been relevant for several years now there could be a bug in the code.



1 Like

Thank you.

This solved it.


Good morning, I have the following error in version 5.1 I have tried to delete everything related to previous versions even in the registry. But it still doesn't work.

See this thread -

Can you run the console version and post the error message?




I have the same Problem.

I have the problem with LinkPlanner 5.1 and 4.9



From the traceback in the second image it appears that there is a problem displaying the Getting Started page. It's possible that there is an error with the encoding of one of the names in your recent file list.

- Click Start -> Run (Windows Key +R)

- Enter "regedit" in the "Open" box

- Navigate to "HKEY_CURRENT_USER\Software\CambiumNetworks\LinkPlanner"

- Right-click on the "file1" entry in the right-hand list and select "Delete"

LINKPlanner should start without errors.



This is a different error - no need to post in multiple threads.