LinkPlanner crashes during opening a project

WIN 10. Just updated to version 5.6.4 and after it opens, I’ll try loading a file or a new project. The project loads, and the left-hand window show good information, but then, it crashes (probably loading the Google map). checked to see if their were any remnants of earlier versions, but no luck. It also complains occasionally about the LinkPlanner.exe.log file that it can’t modify.

Any clues as to a fix?

Try this fix from syadom - Link Planner google maps crash, resolution?.

I use both Malwarebytes and Bit Defender. I incorporated both suggestions excluding the application as well as the LinkPlanner folder. Still crashing.

Here’s the event viewer listing:

Faulting application name: LinkPlanner.exe, version: 5.6.4.0, time stamp: 0x54a38eca
Faulting module name: atl.DLL, version: 3.5.2284.0, time stamp: 0xdfcad7b4
Exception code: 0xc000041d
Fault offset: 0x0000000000006855
Faulting process id: 0x2ea8
Faulting application start time: 0x01d875348303325c
Faulting application path: C:\Program Files\Cambium Networks\LINKPlanner\LinkPlanner.exe
Faulting module path: C:\WINDOWS\SYSTEM32\atl.DLL
Report Id: 7c5d4346-4315-482e-9166-bd658df3a60d
*Faulting package full name: *
Faulting package-relative application ID:

Run the console version of LINKPlanner and send the console output to linkplanner@cambiumnetworks.com.

  • Click Start - Run (Windows Key + R)
  • Enter “cmd” in the Open box and click OK
  • Navigate to your installation directory, e.g.
    • cd “c:\Program Files\Cambium Networks\LINKPlanner”
  • Run the executable “LinkPlannerConsole.exe”

That will display warning messages in the output, which you can ignore. The important information will be just as it crashes.

Thanks,

Andy

Good news in a surprising twist.

Strangely enough, it actually works via LinkPlannerConsole.exe. Load the file, and everything runs smoothly.

But as posted earlier, running LinkPlanner.exe followed by loading a file still results in a crash.

Any insight as to why that would be?

I’m not sure why it would work with the console version, but not the regular exe. Originally you mentioned that you saw the error with the “LinkPlanner.exe.log” file. When you run the console version it should display the error messages that cannot be saved to the exe.log file (Windows prevents applications from writing to the Program Files directory).

This error usually appears if there is an error before the normal LINKPlanner log files have been configured. Can you email your log files to linkplanner@cambiumnetworks.com? To locate your log files:

  • Click Start → Run (or Windows Key + R)
  • Enter “%APPDATA%\LINKPlanner” in the “Open” text box
  • Send me all of the “cambium_linkplanner” log files

Many of the log files are numbered, but make sure to include the “.log” file with no number at the end since that is the most recent file.

Thanks,

Andy