Problems with intermitent 900 Mhz

I have a few customers that are having problems with intermitent 900 Mhz service. There service seems to stop working sometimes for a few minutes and sometimes for a few hours. It never seems to be the same time of a day.

I have asked one of these customers to assist me in troubleshooting the problem. They are located 1.36 miles from the tower. I have taught them how to ping the subscriber unit and how to access the subscriber unit. This is how this customer describes the problem:

Hi. over the last week it seems I have even worse connection and very slow speeds. is anything going on? i ping the subscriber unit and it always has good fast replies. but everywhere else I try pinging has very slow or timed out request when pinged? I opened the subscriber unit page and it says registered, but when I try to click on expanded stats to run link test it comes back with page not found but only on the side bar part? Now after a few trys I can get it to come up. but I have that same problem with 80% of all web pages I try to go to? Very slow precess. When I did get to run link test on canopy page it took several trys to get that page to work right as well. then the results were 100% on up and down load.???

Link Test Results are:

Stats for LUID: 53 Test Duration: 2 Pkt Length: 1522
Downlink RATE: 1234944 bps
Uplink RATE: 319232 bps
Downlink Efficiency: 100 Percent
Max Downlink Index: 97
Actual Downlink Index: 97
Expected Frag Count: 4824
Actual Frag Count: 4894
Uplink Efficiency: 100 Percent
Max Uplink Index: 100
Actual Uplink Index: 100
Expected Frag Count: 1247
Actual Frag Count: 1247

Software Version : CANOPY 7.3.6 Oct 24 2005 12:06:56
Software Boot Version : CANOPYBOOT 3.0
FPGA Version : 020205 (DES) P9
Session Timeout: 17, AirDelay 49 (approximately 1.36 miles (7203 feet))
Session Count: 18, Reg Count 9, Re-Reg Count 18
RSSI (Avg/Last): 2271/2272 Jitter (Avg/Last): 2/1 Power Level (Avg/Last): -51/-51
DnRate(A): 3500 DnLimit(A): 500000 UpRate(A): 3500 UpLimit(A): 500000 (kbit)

I have tried replacing the original integrated subscriber with another integrated subscriber. I have replace the integrated subscriber unit with a connectorized subscriber unit with a 13 dbi yagi antenna. I have mounted the yagi antenna on a pole 8’ above the roof line. I have replaced the RJ45 connectors.

I have 3 each 900 Mhz access points configured for software scheduling. It seems that most of the customers that are having this type of intermittent problems are all registered to the same access point. We currently have approximately 200 registered subscriber units to these access points and this particular access point has 75 registered subscriber units. We have a 6 MB link to our upstream provider.

I have read some of the post concerning interference. I have asked this customer about wireless phones. They have turned off all of the phones and it doesn’t seem to make a difference. I had them turn of their dish network service for a while and that didn’t make any difference. This customer does have a cell phone tower about a 1/4 mile from their house. I have tried changing the frequency on this access point from 906 to 924 which didn’t make any difference.

Does anyone have any suggestions on how I might be able to troubleshoot or fix this problem?

First, I would recommend not allowing customers to access your infrastructure. Next, do you use NAT, VLAN, or port filters?

Are you using 7.3.6 on the AP as well? Have you plugged a sniffer in at the CMM to see if there is large amounts of traffic (broadcasts & multicasts) coming from one or two units?

I would recommend port filters enabled, AP isolation on the CMM (port based VLAN), SM Isolation (need to upgrade to 8.1.4).

If the SNR is good, and the link quality is good then the next thing would be a virus or virus like activities.

The subscriber units are NAT to the WAN port on our Mikrotik router. We do not have any VLAN(S) and have not used any port filtering. We are currently using 7.2.9 on the access points. I upgraded a few subscriber units including this one to 7.3.6 to test how it worked. This subscriber unit was having this problem when using the 7.2.9. We have not tried plugging a sniffer into the CMM Micro but last night we installed a NetEnforcer between the subscriber units and the LAN port on the Mikrotik router. The intial monitoring has not revealed any unusal traffic patterns. Would using a sniffer at the CMM Micro be different than using the NetEnforcer? This customer has been having this problem for almost a full year and has done several full scans for viruses. I will follow up on your suggestions to enable filters, isolate AP on the CMM (port based VLAN), upgrading to 8.1.4 and SM Isolation.

I assume that you are using a CMM to provide timing to the AP’s?

You really want 900’s to be running in Hardware Scheduling. You can use the CNUT plugin to change all SM’s on an AP to Hardware at the click of a button.

Look for the post regarding balancing RF levels

Be sure you are running 7.3.6 on all AP’s and Access Points

Have the customer configure his computer to be on the same subnet as the SM, do a spectrum analysis, take a screen shot, and email it to you. Then post it somewhere and link to it here.

Thanks for the suggestions. We are using a CMM Micro to provide timing to the AP’s.

My plans have been to eventually switch to hardware scheduling. Do you think that 75 subscribers units registered to AP would still work with hardware scheduling? This is one of the reason that I have hesitated to make the switch. Another reason that I have hesitated is that I am concerned that the switch to hardware scheduling might cause some of the marginal units to completely quit working. In your experience is there any reason to be concerned about the affect on marginal units?

I read the post on balancing RF levels. I have looked in my access points and the average power levels range from -38 to -86. If I understand the post on balancing RF levels, I would adjust the power levels of the subscriber units beween -76 and -86. Is this correct? How do I adjust the power level? Will I have to go to each subscriber unit and aim it until the power level is in this range?

Thanks again for all of the suggestions. They are much appreciate.

Can you tell me how to change to hardware scheduling on all of the subscriber units using CNUT. I have looked in CNUT but could not figure out how to do it. Would I change all of the subscriber units and then change the access points?


You will use the transmit output power setting on the SM to incrementally lower the power level (as indicated on the AP sessions page). Make small adjustments…lowering the level too much too quickly can result in stranding the SM and thus a truck roll.

I think if I were in your position, I would follow this procedure

1. Lower the levels on the hottest SMs so that they are below -65dB.
2. Switch to HW scheduling (weaker SM’s will improve)
3. Let it settle for 24 hours
4. Tweak the RF levels more closely. I don’t think I would go lower than about -70dB though, even if the weakest is still down around -86dB.

The fact that you have SM’s registered at -86 tells me you have a very low 900MHz noise floor (below -90dB) . The RX threshold of the 900SM is -90dB so you are right on the edge. I think once you make the change to HW scheduling you will see levels come up a little bit.

To make the change you need to use the scheduling tool plugin for CNUT. The tool will switch all of the SM’s, then the AP. If any of the SM’s that were present in SW mode do not come back you will get a warning. You can then switch back to SW, change the orphaned SM’s, and then switch back to HW.

We switched over 100 SM’s and did not lose one. SM’s that were right on the edge in SW registered immediately and were more stable in HW.

From your first post, and the client’s description of the problem, I would look at your ethernet run to the radio at the client’s site. It sounds to me like the problem might not be your link to the AP at all, but maybe a bad ethernet end, or a bad power supply. Could also be the client’s ethernet interface. Do you have a surge protector installed? If so, check the ground, we’ve seen bad house wiring cause this with ground connected. Disconnect the ground from the 300SS and all is well. Take a notebook computer on site and eliminate the client pc first, and work back to the radio from there.

Good luck!

That could be true as well and definitely should be looked at.

However, you still want to be running in HW mode. It’s so much better than SW you won’t believe it.

Get a spectrum analyzer on ebay that can go down to -90dBm and that can display 902-928 mhz.

Bring it to the customer site and have them use things like wireless headphones, cordless phone, etc. I’ve seen 5.8GHz cordless phones that used 900MHz as an Intermediate Frequency, hosing the canopy SM on the roof with a very strong signal from the base that wasn’t properly shielded.

twinkletoes, is there a spectrum analyzer you recommend off of ebay?

I really like the Avcom stuff. They sell brand-new 2.4GHz analyzers that go for $3000 and they have 5-6GHz and 600-1000MHz adapters to it (that have an oscillator and a mixer) for it for $695 ea. Their tech suport is also pretty good. If you get it used, it’s $300-$600 on ebay. I couldn’t find the adapters used so I paid more for them on then I paid for the analyzer on ebay… Avcom doesn’t give you the features or accuracy of a $40,000 analyzer, but you don’t need it for this kind of job.

The Avcom 2.4GHz analyzer has an LCD, not CRT, but unlike some of the cheap LCD units, this one is actually pretty decent. They make other ones with CRT that cover other various frequencies and they’re all pretty decent. Avcom focuses on markets of guys like us and also cable guys and so forth.

There’s also some on ebay that sell “new” from Hong Kong for under $1000 and give you 100-1000MHz or something like that. I’ve never bought one, but they look decent enough.

Overall, you want to look for two qualities:

1. Covers the spectrum that you want to troubleshoot
2. Has enough sensitivity to be useful (If your customers are linked up between -70dBm and -85dBm and your analyzer only goes down to -50dBm then you MAY or MAY NOT see the spikes go up into the range that your analyzer can see. Also, keep in mind that you probably aren’t going to be waving around an M2 17dBi yagi in someone’s living room, you are going to be using a small hand-held 8 to 12dBi yagi…)

I also think it’s very interesting to use analyzers up at tower sites to see what your signal looks like from your AP antennas, both before and after filters (cavity filters, notch filters, bandpass filters, etc.). This can give you a good view of what you are up against with interference at a particular site. A good analyzer gives you quite a bit more detail then the built-in canopy spectrum graph, although the graph is very, very helpful all by itself!

Pop this item number into ebay search: 140064107280

and you will see one of the numerous hong-kong jobs I was talking about. The specs and the price both look excellent. I’ve bought plenty of other stuff from these hong kong electronics vendors on ebay and I’ve never been ripped off, if that helps :slight_smile:

This is cheaper than the Avcom 900mhz adapter, and it’s the whole thing. If you run a 900mhz network and you don’t at least have one of these, you are really missing out. There’s tons of interference all over the 900mhz band.

Another thing you can buy are fixed or variable attenuators. I have an army of fixed attenuators from 5dBi to 40dBi and I use them so that I can plug radios directly into the analyzer to see if one radio acts like the next. I also use them to plug in PtP radios back-to-back and test them with 60dB, 80dB, etc levels of attenuation. Only the 900mhz “connectorized” canopy gear applies here, unless you are buying adapted APs off ebay or from paul S@ fddi systems.

Thanks for all of the suggestions. I have been implementing these suggestions as quickly as I can. The first suggestion that I implemented was the RF balancing which really reduced the number of re-reg. Yesterday, morning I switched to hardware scheduling which made a significant improvement in the performance of the network by 2 and 3 times the previous performance. It seemed that the number of re-reg’s increased after the change to hardware scheduling so I updated the AP and Subscriber Units to 8.1.4. There still seems to be a lot of re-reg. Is this normal? Also, it seems that the lower the power level the more re-reg’s i.e. more re-reg’s for -54 than -70 which is the opposite of what it was with software scheduling. Is this normal?

To summarize:
You worked on balancing the RF levels and the re-reg’s went down
Then you switched to HW scheduling and the re-reg’s went up
Then you upgraded to 8.1.4 and the re-reg’s did not improve.
Your radios at -54 (stronger) seem to re-reg more than your radios at -70 (weaker).

To clarify:
You still have radios at -54 that you are calling “lower”. You are aware that -54 means a stronger signal?
You are looking at the AP sessions page?

If the above is true:
Work on balancing the RF levels at the AP. -54 is significantly higher than -70dB in terms of power level.
Check that all of your (and any other) 900 AP’s within 10 miles of each other are configured with the same
- Max Distance
- Control Slots
- Downlink %
Check for sources of interference in the 900MHz band
Confirm you have enough Control Slots for the # of subs

Very good summary. I have lowered the transmitter output power on several of the subscriber units to 4 and the power levels shown on the AP sessions page are still in the low -50. Is there anything else that I can do to lower the power level? The transmitter output power on the access points is set to 28 dBm.

The user manuel recommends in table 41 that the number of control slots for 51 - 150 subscriber units registered to the AP should be 2. I have 2 access points with over 50 registered subscriber units and 1 access point with less than 50 subscriber units. Should the setting for control slots be the same on all of the access points as recommended in table 40 or does this note in table 40 only apply to software scheduling? The access points are currently configured for 0 control slots.

The max range is set to 12 miles. Our max distance for any of our registered subscriber units is 8.32 miles. The closet 900 Mhz access point to this cluster of access points is 12.75 miles. Should I try setting the max range to 10 miles? I don’t plan on installing in new subscriber units beyond 6 miles. I have read several posts that discussed the max range setting and some differences of opinion on how to set this parameter.

The downlink % is set to 75. Thanks for all the help.

I would configure them as follows:
75% downlink as you currently have it
10 miles max distance
2 control Slots (the one AP with less than 50 will fill up soon enough)

As for the power levels, are you using connectorized or integrated SM’s? If they are integrated, you could try aiming the SM up or down, or off-axis. If they are integrated, you could try a lower gain antenna.

I just recently dropped my mileage to 10 miles on a Friday and had a customer call in that was on a yagi at 8 miles away and could not connect The reason behind this is while I was watching the SM try to register it would show that it was 20.05 miles away in the registering screen. I changed the mileage up to 25 miles and it came right up.
Another instance I was getting a customer that could not stay connected “pppoe” for more than an hour and a half. When I extended that mileage it will stay connected now. I have no idea why but that was the last thing I changed in the AP.
Also it is a lot easier to change power levels in ver. 8.1.4.

these issues you are experiencing are with 8.1.4?

Please contact tech support to let them know what’s going on.