ePMP Software Release 4.7 is now available

Software and release notes can be downloaded at:

New Features

Security

System release 4.7 requires passwords be changed away from their defaults. For more information, please see this Knowledge Base article:

Smart QoS and Deep Packet Inspection

System release 4.7 includes new QoS features. For more information, please see this Knowledge Base article:

Deprecation of older SSH algorithms

System release 4.7 deprecates some legacy SSH algorithms. For more information, please see this Knowledge Base article:

Problems Corrected

Tracking ID Products Description
ACG-9426 All Support for the Max MCS feature for ePTP mode.
ACG-10135 All Device UI allowed to switch channel bandwidth to 10 MHz when 30/70 TDD ratio was configured.
ACG-10395 All 802.11ac and 802.11n platform device reboots were counted as hard device reboots by Watchdog configured in the UI.
ACG-10686 All When the Spectrum Analyzer Tool detects an AP operating in the ePTP mode as Wi-Fi Interferer type.
ACG-10998 ePMP 3000, Force 300-25, PPPoE The wireless connection dropped between an AP and an SM due to PPPoE session interruption when the PPPoE client was configured at the SM.
ACG-11007 Force 300-25 Force 300-25 was reporting a higher value for Noise Floor than the actual value.
ACG-11026 ePMP 3000 Smart Antenna connectivity issues on ePMP 3000.
ACG-11294 ePMP 3000L Improved ePMP 3000L stability.
ACG-11528 All ePMP and PTP 550 were crashing with the signature allocated:camb_sn_tx_complete.
ACG-11959 All Allows the selection of the speed options announced in auto- negotiation mode.
ACG-12098 All Any setting changes of the Ethernet port caused a wireless link to disconnect.
ACG-12380 All The usernames were not displayed in the System Log correctly when using a RADIUS server.
ACG-12517 Force 300-13, Force 300-25L, Force 300 CSML Force 300-13, Force 300-25L, and Force 300 CSML were not able to obtain IP through DHCP occasionally.
ACG-12622 ePMP 3000L, Force 300 CSM The highest available frequency for ePMP 3000L and Force 300 CSM were limited to 6070 MHz.
ACG-12670 ePMP 3000 The maximum DL MCS per SM did not operate at the configured MCSs.
ACG-12758 Force 300 CSML Force 300 CSML was freezing occasionally in the Initializing Upgrade… state, after attempting to upgrade the software using the URL Upgrade Option.
ACG-12762 Force 300-25L License Keys were not applied to devices locked to the Indonesia country code.
ACG-12947 All Corrected valid center frequencies for Australia country code.
ACG-13016 All System Log was fully loaded with Smart Antenna status messages.
ACG-13096 All MPLS traffic was not passing through PTP 550 occasionally.
ACG-13104 Force 300-25, Force 300-13L The Fallback IP address did not work for Separate Wireless Management Interface.
ACG-13217 All MU-MIMO performance enhancements in Flexible mode.
ACG-13357 All Multiple stability enhancements in Flexible mode for disconnect and reboot .
ACG-13377 All After enabling Smart QoS and DPI, ePMP APs stopped working.
ACG-13448 ePMP 3000L Multiple stability enhancements for ePMP 3000L.
ACG-13493 All LEDs were not blinking on PTP 550 devices.
ACG-13505 Force 300C, Force 325L In Force 300C and Force 325L, did not able to configure Max Registration Allowed more than 1.
ACG-13561 Force 300-25 RSSI level degradation was detected on Force 300-25.
ACG-13562 ePMP 3000 MPLS traffic acceleration support is added on ePMP 3000 and PTP 550.
ACG-13692 Force 300-13L In AP mode, only one SM was able to connect to Force 300- 13L.
ACG-13778 ePMP 3000 EoIP traffic acceleration support is added on ePMP 3000 and PTP 550.
ACG-13821 Force 300 Multiple stability enhancements for Force 300.
ACG-13841 ePMP 3000, Force 300 General throughput performance enhancements.
ACG-13853 All Force 300 CSM in AP mode was limited to 1 SM (Registration allowed) only.
ACG-14019 All When DPI was enabled, a new session was not established through ePMP link.
ACG-14123 All If Management VLAN was enabled, L3 firewall did not limit access to ePMP device/ PTP550 UI.
ACG-14381 All If Data and Management VLANs are enabled on ePMP SM, PPPoE client on ePMP SM cannot establish the connection with PPPoE server.
ACG-14382 All If DPI and Smart QoS are enabled, ePMP devices crashes occasionally.
ACG-14402 ePMP 3000 MP If more then 13 SMs are connected to ePMP 3000 MP , then UI was unresponsive occasionally.
CAMBIUM-17168 Force 200 Force 200 had false RADAR detections.
CAMBIUM-17326 ePMP 1000, ePMP 2000 The L2 and L3 Firewalls were not operating as expected, and were passing packets blocked in the configuration.
CAMBIUM-17985 ePMP 1000 The RSSI fluctuated significantly while using the eAlign tool in ePTP mode.
CAMBIUM-18033 Force 200L Multiple stability enhancements.
CAMBIUM-18111 All Elevate support for the Intelbras WOM-5A-23.
CAMBIUM-18112 ePMP 2000, Force 200, ETSI-5G Due to packet loss introduced with Short GI configured on 802.11n devices, Long GI was forced for 5/10 MHz bandwidth.
CAMBIUM-18153 All DL/UL traffic got stucked at some MT Elevate LHG5 devices.
CAMBIUM-18183 All Support for a feature that allows selecting the speed option announced in auto-negotiation mode.
CAMBIUM-18185 All RADIUS authentication was not working in ePTP mode.
CAMBIUM-18255 All Support for an Enhanced Port Forwarding rule that allows users to specify ports 22, 23, 161, 80, and 443.
CAMBIUM-18276 All If some ePMP 1000/2000 with GPS sync devices report the GPS Firmware version in the wrong format, then invalid alarms in cnMaestro was triggered.
CAMBIUM-18289 Force 180 6GHz The auxiliary Ethernet port was displayed in UI by mistake on F180 6 GHz devices.
CAMBIUM-18308 All The valid center frequencies in the range 5725-5850 for the Australian country code is updated.
CAMBIUM-18398 5 GHz Force 200L Radio V2 Support of Tx Power in range -24 dBm
CAMBIUM-18440 All After any configuration changes, PPPoE connection was not reestablished at Elevate devices.
CAMBIUM-18447 ePMP 2000 Did not able to start tcpdump command in CLI.
CAMBIUM-18464 All Ethernet port had Down indication on UI, but was working on ePMP 1000 (6 GHz).
CAMBIUM-18511 All Elevating MT devices to ePMP Firmware was not possible.
CAMBIUM-18629 All 802.11n SMs were rebooting for high traffic occasionally.
CAMBIUM-18869 Force 300-25, Force 300-13L Fallback IP address did not work for Separate Wireless Management Interface.
CAMBIUM-18931 ePMP 1000 The default date is changed to 2022 for 802.11n and 802.11ac generations of ePMP devices.
6 Likes

Where are we supposed to purchase the Smart QOS license. I cannot find it anywhere

I think it should be available from the usual Cambium distributors, although Google doesn’t seem to be showing many results. Here’s one though:

https://www.wavonline.com/products/cambium-networks-qe-e3000-01a-ww/p-171259/

1 Like

Is there a video showing the Smart QoS in action?

2 Likes

I just loaded an AP running the new v4.7 and “Current Applications Usage” shows Facebook at the top. I hover my mouse over the bars (What is Cambium’s deal with hovering the mouse over things ? Why can’t there be numbers there!?) and it says 2.8MB / 400kB . Ok so MegaBytes and KiloBytes so this must be a Total since … since when? Then it refreshes and now FaceBook is 1.3MB / 20kB ? It went down? Sooo is it a total since the last refresh ? How is that useful ? Why not just give bits or bytes per second ? Or is that per second ? The default refresh is 5 seconds so is it giving a 5 second average of Bytes per second or is it maybe the Bytes per second the second of the refresh ? And if it is then why Bps instead of bps ?

And the 10 little bars you have to hover over, I assume sticking with the ePMP theme of making sure people can’t see more than a single piece of useful data at one time, what are they supposed to represent ? Are they "percent of total usage since the last refresh ? " So each bar is 10% ? No that doesn’t work because the top thing can be all bars (100%?) and the 2nd thing on the list 3 bars. I could understand all the other things having 1 bar meaning, not 10% but they did do some tiny bit of data and 1 bar is the least number of bars we can light up but 10 bars on Facebook and then 3 bars on the 2nd thing (Not Detected) that would be 130% so that’s not it.

Edit: Just noticed the " Data Throughput Chart - Downlink" at the bottom of the page that displays, nothing. Even though the top of the page says the AP is moving anywhere from 3 to 10Mbps and the “Current Applications Usage” is showing data downloaded from Facebook and " Not Detected " there is absolutely nothing on the chart at the bottom.

I see that the things listed under " Overall Applications Usage" have boxes next to them you can check/select ? I thought maybe the things selected would appear in the “Data Throughput Chart - Downlink” graph but checking/selecting applications doesn’t appear to have any affect on anything.

Maybe I need to select them and then save ? No, selecting or unselecting applications does not light up the “save” button.

1 Like

We put 4.7 RELEASE on all our ePMP 1000 (2.4 Ghz) / 2000 / 3000 series, and all seems well.

The only issue we see is the known cosmetic issue of certain SM’s showing up with blank ‘device names’ in the AP’s list – which has been tracked down to their device name being a certain length or containing a certain string of characters.

So far, so good… working well on all 1000 / 2000 / 3000 series gear.

3 Likes

We installed 4.7 on a 2.4 ePTP link in a high noise environment feeding a a small mini
pop through some trees a couple of miles distant. The link had been problematic and we were on the verge of swapping it to an AF2X but since we moved to 4.7 it has been stable so KUDOs for the ePTP tweaks…

5 Likes

7 posts were split to a new topic: SNMP issues with ePMP Software Release 4.7

We’ve deployed 4.7 on our entire network and the one thing that really stands out is the reduced latency. Great work!

3 Likes

Are you sure? We didn’t notice such thing…

4.7 has been out for a few weeks now, how is this running for everyone who has upgraded? Anybody tried the STA release yet?

Yep, we’re running 4.7 on everything and have the STA release deployed on all 5GHz radios. Everything is working great!

1 Like

I’ve seen performance improvements with 4.7 mentioned in the forums. But it’s not clear to me whether those improvements are applicable to 2000 APs with F200 SMs.

Hi @3-dBnetworks,

yes, you should observe improvements on N-radios too. There was a bunch of changes in scheduler algorithm and stability improvements. In other words fixes covering corner cases from our customers’ networks related to latency and tput.

What is wrong with the traceroute from the CLI?

AP_TEST>traceroute --help
BusyBox v1.25.1 (2022-11-23 17:36:19 UTC) multi-call binary.

Usage: traceroute [-FIlnrv] [-f 1ST_TTL] [-m MAXTTL] [-q PROBES] [-p PORT]
[-t TOS] [-w WAIT_SEC] [-s SRC_IP] [-i IFACE]
[-z PAUSE_MSEC] HOST [BYTES]

Trace the route to HOST

    -F      Set don't fragment bit
    -l      Display TTL value of the returned packet
    -n      Print numeric addresses
    -r      Bypass routing tables, send directly to HOST
    -v      Verbose
    -f N    First number of hops (default 1)
    -m N    Max number of hops
    -q N    Number of probes per hop (default 3)
    -p N    Base UDP port number used in probes
            (default 33434)
    -s IP   Source address
    -i IFACE Source interface
    -t N    Type-of-service in probe packets (default 0)
    -w SEC  Time to wait for a response (default 3)
    -g IP   Loose source route gateway (8 max)

AP_TEST>traceroute -n 192.168.101.1
Syntax error: Illegal command line

Hi @Willi_Gruber,

arguments should be in quotes.

e3k_cs>traceroute “-n 8.8.8.8”
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
1 10.1.11.71 1.958 ms 2.207 ms 1.049 ms
2 172.22.123.1 2.227 ms 1.037 ms 2.246 ms
3 172.17.62.9 2.219 ms 2.221 ms 2.242 ms
4 195.238.92.68 2.249 ms 2.281 ms 2.184 ms
5 95.67.4.121 3.330 ms 2.233 ms 2.241 ms
6 95.67.1.28 10.577 ms 10.547 ms 11.765 ms
7 * * *
8 108.170.248.155 3.381 ms 3.467 ms 3.478 ms
9 142.251.242.39 29.804 ms 142.251.224.82 30.785 ms 72.14.239.111 3.388 ms
10 216.239.35.133 29.696 ms 29.670 ms 108.170.250.209 30.854 ms
11 108.170.250.209 31.021 ms 216.239.40.43 31.928 ms 142.250.238.1 30.787 ms
12 142.250.224.89 32.037 ms 8.8.8.8 29.660 ms 142.251.65.223 30.863 ms

I will create an engineering ticket to add this note to help output. It is the same for all Linux tools in our CLI. Thank you!

1 Like

I’m not able to upgrade an ePMP 3k on version 4.6.2 to 4.7 from cnMaestro, this is the third time I try, and I have to (once again) go the the site to uplug/plug it again. Is there any recommended upgrade path I should be aware of?

I think we are seeing the same thing going from 4.6.1 to 4.7. The first 3000 I upgraded had all AC clients (not sure if relevant) and went through (using CNMaestro) without a problem. The 2nd 3000 was also all AC clients and went fine. The third 3000 has more N than AC (again, not sure if relevant) and all the clients upgraded just fine however the AP became unreachable. The logon screen would load but just go gray when you enter the password and try to logon, ssh just timed out, SNMP got no response but it was pingable and clients were connected and working. Had to go onsite and powercycle and it came back up with 4.6.1 in the active bank and 4.7 in the inactive bank. Did the upgrade manually via web interface and it worked. Third 3000AP did the same thing (mix of N / AC upgraded SM’s first then AP via CNM).

Haven’t tried a 4th yet, but thinking maybe I’ll try CNM to upgrade SM’s and then manually do the APs and see how that works out.

3rd time I’ve tried on that particular AP worked from the Web UI, now, I’ve tried the upgrade again with other two APs using the Web UI, and isn’t working, I will have to go on-site again (ugly experience :), restart, and try again. It’s very inconsistent, but 90% of the time the upgrade for AP doesn’t work. Cambium team, any feedback on this?

We upgrade hundreds to 4.7 without any much issues. The only time we’ve had inability to upgrade in the past, is when memory is low. This might not be your situation, but that’s bit us a couple times before. So, we’ll turn off all things that don’t need to be on (certainly the Spectrum Analyzer if it happens to be on, will likely screw things up) but any other services which don’t need to be running during the upgrade, that seems to help.

We also have ethernet equipped smart power bars on AP’s, so we can power cycle them from the shop. :slight_smile: That helps a keep 2 AM drives to a minimum. :smiley:

2 Likes