PoE problems with TX2012R-P

We are experiencing some really strange behaviours with cnMatrix TX2012R-P.

We are running 4.3-b6 firmware to put hands ahead who which ask about that.

Port#1 => Albentia BS-450-N - passive-54v/802.3 from ds. passive-54v works. 60W
Port#2 => Mikrotik CCR1009-7G-1C-1S+PC - passive-54v from ds. None config works. 38W
Port#3 => ePMP 3000 - 802.3 from ds. 802.3 Works. 25W
Port#4 => intentionally left empty for future products needed more than 30W
Port#5 => Mimosa C5c - passive-54v from ds. passive-54v works. 9.2W
Port#6 => Mimosa C5c - passive-54v from ds. passive-54v works. 9.2W
Port#7 => ePMP 3000L - passive-24v from ds. passive-24v works. 15W
Port#8 => ePMP 3000L - passive-24v from ds. Stay in detecting forever. 15W

Let’s talk about Mikrotik CCR. If I try to connect only the device on port 2 it won’t power up with any PoE settings. If I try leave the cable connected on port 2 and I connect for example the C5c on port 5, magically both port 2 and 5 power up. As if two ports were related to each other.

If I try to disconnect even a single cable of those working on passive-54v, all devices connected turned off for such seconds and then restarted.

Strangerly LLDP detect Mikrotik connected on port 3 instead of correct port 2. No other products detected on other ports. Neither Cambium devices.

After connecting the second 3000L on port 8 it won’t power up and port remain in “detecting” state. If I disconnect same cable and I use a power supply, the radio start normally. More if I connect always same 3000L on Netonix switch with 48V setting, the radio start normally without a single problem.

Into the lab we had so many problems turning on Mikrotik equipment that we thought there was some sort of incompatibility here. Many Mikrotik products won’t power up and ports signal Other fault 34 error or with different numbers.

We are having really many difficult to use those switches on our networks. Unpredictable behaviour is not what a WISP would obtain in their network.

A ticket opened on 16th of May, with a infinite series of ridicolous reply by support team. An answer above all:

" In your configuration you have power inline never on port 4. Please remove that command and retry ". Yeah man. All good but port 4 is not used. The port was intenionally left empty.

Really disappointed by Cambium in general since release of 3k radio. Even on 3k radio we have had many problem due to a bad noise management compared to 1k series. We have been forced to change 90 degrees original Cambium panel antenna with 2x 30 degrees RF Elements horns to obtain same total bandwidth (around 70 Mbps) we already had with an old 1k GPS sync radio on same 20 Mhz channel spacing. With one simple difference: price.

Now we are having many trouble with cnMatrix switches and fighting between distributor and Cambium itself. Distributor ask us to make other tests but we need to move to the tower really early in the morning to reduce service interruptions on a site with almost 200 active customer. Cambium support ask us to make some ridicolous modify to configuration with no sense here. They both forget that we small providers have to work and not experiment on our networks.

From our point of view, the reality here is very simple: Cambium is releasing products with immature hw/sw release and they are using WISPs like beta-tester correcting problems from time to time. This is happened with 3000, 3000L and now with cnMatrix, and I have an idea that it will work like this in the future.

I think Cambium should really stop to think only to sell and make great marketing job and come back to make good products because we are expecting just that. The excessive desire not to lose market shares is producing equipments that does not live up to expectations for those who have always known Cambium as the leading company in the WiFi world.

1 Like

@telecomunicazio we too are a small wisp and are having small issues with the TX 2012R-P, I have one randomly rebooting on its own, tried multiple AC power supplies and even used a DC one, same result. Swapped it out with another TX 2012R-P and problem went away… now the new switch is losing sync and the fix is to disable and then enable the sync port power state.
Tried RMAing the switch that randomly rebooted itself, support suggested upgrading to 4.3.r3… dont think it will help. I cannot for the life of me figure out why the cambium sync state randomly goes to “not in sync”

Sorry none of this helps your specific issue… as far as our POE ports on the switch all are working fine…
Port#2,3,4 and 5… EK3 all using 802.3 no issues
Port# 8 Passive 24v Ubiquiti Powerbeam 5AC no issues.

1 Like

@telecomunicazio so now I have a switch that is getting a fault with a 24v ubiquiti powerbeam connected to it… @cambium?

@telecomunicazio any development or news to what you are experiencing? Any resolutions?

new switch received from RMA.

Same problem. Mikrotik switch netPower Lite 7 accepting 54v no power up with any settings. I tried in lab with this switch that is similar to CCR1009.

We will try on tower with CCR1009-7G-1C-1S+PC

Finally I understood what is the problem with some Mikrotik stuff.

On Mikrotik datasheet of CCR1009-7G-1C-1S+PC routerboard was reported Passive 54v but no specification what pin of ethernet cable it use to transmit power. After some serching, looking at power adapter, I saw only 4,5 for + and 7,8 for -. No other pin used.

So I watched about what pin cnmatrix use to push power and from this doc 24V and 54V PoE Pinout details for cnMatrix EX/TX series switches you can clearly see following:

For all cnMatrix switches, our 2 Pair PoE (2PPoE) delivers 54V following Alt-A (MDI-X) polarity wiring. 2PPoE delivers up to 30W from the PoE port:

1/2 (negative)
3/6 (positive)

This configuration is not good for mikrotik of course.

For our 4PPoE implementation (up to 90W power), we implement the 54V as Alt-A (MDI-X) from the data pairs, and Alt-B from the spare pairs.

1/2 (negative)
3/6 (positive)
4/5 (positive)
7/8 (negative)

neither this configuration is good for Mikrotik because it can’t manage current on 4 wires.

When in Passive 24V mode, we switch off the 54V power on the data/spare pairs, and turn on 24V on the spare pairs following Alt-B.

1/2 (off)
3/6 (off)
4/5 (positive)
7/8 (negative)

this is only compatible configuration with Mikrotik but in case of this CCR is not enough because it consume minimum 33Watt while with that configuration cnmatrix is capable to erogate only 15Watt.

In fact creating an ethernet cable with following wires configuration:

side A => normal standard B colors (white orange, orange, white green, blue, white blue, green, white brown, brown)
side B => white brown, brown, blue, green, white blue, white orange, orange

the Mikrotik powered up on block 2 ports (purple) because with that cable I send current on 1/2 (negative) and 3/6 (positive). The only problem are the data. Obviously it won’t communicate due to a wire inversion.

Teorically it could be possible to use a cable to power up Mikrotik and an SFP 1000BASE-TX port (for example) for data. In that way it work for sure. It’s a workaround at moment.

The best should if Cambium could send almost 40-45 Watt on only 2 wires in 4PPoE implementation using only 4/5 for positive and 7/8 for negative making a software modify.

1 Like

I would explain better my previous post because probably something is not clear.

First thing is that many Mikrotik hardware accept poe-in only using 4/5 for + and 7/8 for - as you can read here (Manual:PoE-In - MikroTik Wiki).

If you read my previous post, the only PoE configuration to use to try to power up devices that consume more than 15 Watt, is 2PPoE capable to push until to 30W.

Now following cnMatrix pinouts for PoE, 2PPoE 54v 30W config use 1/2 for - and 3/6 for +.

The idea is to use a special cable to create a match between 1/2 to 7/8 and 3/6 with 4/5 pins.

In this way the Mikrotik surely power up but first problem is you can power products that consume no more of 30W and you can’t use same cable to exchange data.

In our case we operate in Europe so we should use EIA/TIA568B so the cable is done in following color scheme:


In that way + is on pin 4 and 5 while - is on 7 and 8 as required by Mikrotik products.

Now I ask to @CambiumMatt if I can use a special cable made in way I can use 4PPoE 54v 90W config.

If Mikrotik accept only 4/5+ and 7/8-, can I tie togheter 1/2/7/8 for - and 3/6/4/5 for + to the side B of ethernet cable to deliver proper voltage and power the product?


1 Like