Samba Server setup

Hi, I have a 2TB external HD formated to FAT32 that I am wanting to connect to my R201P. I want to be able to transfer files to the HD as well as access the files from other devices such as Windows PC's, Smart TV, WD media player & android phones.

I do not understand how to set up the device. Can someone please step me through doing this?

Thanks Brian

Hi Brian,

You will have to

1. Copy your data to be shared into /home/anonymous folder in your drive

2. connect the drive to the R201P device

3 On the device UI do the following under Storage TAB

3.1. enable FTP server (and anonymous Login)

3.2 enable Samba server 

3.3.Add your directory to the "Sharing Directory List"

4. Do this from the wireless client connected to R201P

And you should see the shared files.



Thank you for the reply. I have followed the steps outlined, but I must be doing something wrong

1. I am testing on a USB. I have a folder on the USB named "/home/anonymous" & plugged it into the R201P.

2. I have enabled FTP as per the screen shot attached.

3. I then go to SMB settings and enable & under shared directory list I select add.

4. Every name I have tried in the add directory name field (see screenshot) is either rejected or I get a "no directory" message.

Any other pointers to get this working?




You have to connect you USB drive to a laptop/PC,

then create the below folder hierarchy,  if not already present.


home -> anonymous

(Please refer to screen shot)

copy your files (to be shared) to the "anonymous" folder

then connect the USB drive to R201 device. 


Hi Ashutosh,

                      Yes, here is a screen shot of how the folders are set up. I then plug it into the R201P. What directory name do I add to SMB settings?



If you have enabled ftp server and samba server, try accessing the ftp url from the wireless client.

Sorry but I can't enable samba server as I don't know what name to add to the directory name field as shown in the screen shot.

Everything I have tried must be wrong.



That is a user defined folder name. Put anything.



   I have tried using various names such as home, files, shared and nothing is accepted, I get the pop up message as shown in this screen capture.



Hi Brian,

 are you on skype? Please add me and we can discuss and close this.


is my skype id

I have added you to skype. I only have this on my phone at this stage. I work full time so will not be available until after 6pm Australian Eastern Standard time.

Thanks to Ashutosh for putting together the taskcard in the link below. Easy to follow and now it works no thanks to a possible faulty USB drive.

Use internet explorer and it will work. There's a bug with Chrome.

4 posts were split to a new topic: Trouble with cnPilot file sharing